PHP5.3.x安装Zend Guard Loader

PHP5.3安装Zend Optimizer,已经被正式改成了“Zend Guard Loader”,简单来说,就是不需要安装软件,而是直接在php.ini中调用组件(扩展)即可。

简单理解就是这个版本不支持PHP5.3以下版本的Zend Guard编译,所有文件要重新按5.3版本进行重新编译。那这里的Zend Guard版本,就要求升级为最新版,因为我们知道Zend Guard4只能按PHP4、PHP5两个版本加密,而最新版本的Zend Guard加密时可选的PHP版本只剩下php5.2、PHP5.3两个版本了。如果不出意外,以后版本中Zend Optimizer将不复存在,取代的就是“Zend Guard Loader”,不管什么优化、加速、保护功能全通过此功能加载。听起来好像类似于App扩展。

Guard Loader 的用法和以前没什么区别,都是在php.ini“最末尾”添加一句命令引入文件就行。

1
zend_extension=<full  .DLL .so to path>

说一下这里为什么要使用“最末尾”,这里是个人建议,因为用时候会出一些莫名的问题,如不能正常载入Zend,不能读取PHP文件,尤其表现在和eAccelerator载入顺序冲突等。

以下是操作的shell片段:
第一步,通过探针或者PHPinfo查询到当前加载的php.ini

Loaded Configuration File:/etc/php5/apache2/php.ini

第二步,下载扩展

wget http://downloads.zend.com/guard/5.5.0/ZendGuardLoader-php-5.3-linux-glibc23-x86_64.tar.gz

Windows下为

http://downloads.zend.com/guard/5.1.0EA/ZendGuardLoader-php-5.3-Windows.zip

第三步,解压,提取ZendGuardLoader.so,Windows下叫ZendLoader.dll,放到PHP的ext目录下(推荐,不是必须)
第四步,编辑php.ini,添加相关配置信息

vi /etc/php5/apache2/php.ini
zend_extension=/usr/local/zend/ZendGuardLoader.so

或者

[Zend.loader]
zend_loader.enable=1
zend_loader.disable_licensing=1
zend_loader.obfuscation_level_support=3
zend_loader.license_path=
zend_extension="c:\php\ext\ZendLoader.dll"

最后,重启Webserver。

PHP5.3.x安装Zend Guard Loader:等您坐沙发呢!

发表评论

表情
还能输入210个字